1inherit meson systemd
2
3SUMMARY = "ATTN and HwDiags Support"
4DESCRIPTION = "Attention Handler and Hardware Diagnostics"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
9
10SYSTEMD_SERVICE_${PN} = "attn_handler.service"
11PV = "0.1+git${SRCPV}"
12SRCREV = "8af9e46f43d2ffa030275d17716571d4fcc8ad18"
13
14S = "${WORKDIR}/git"
15
16DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
17           nlohmann-json"
18
19FILES_${PN} += "${UNITDIR}/attn_handler.service"
20
21# This is required so that libhei is installed with the chip data files.
22RDEPENDS_${PN} += "openpower-libhei"
23