1HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
2SUMMARY = "Hardware Diagnostics for POWER Systems"
3
4DESCRIPTION = \
5    "In the event of a system fatal error reported by the internal system \
6    hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
7    POWER Systems have the ability to diagnose the root cause of the failure \
8    and perform any service action needed to avoid repeated system failures."
9
10PV = "0.1+git${SRCPV}"
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14inherit meson systemd
15
16S = "${WORKDIR}/git"
17
18SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
19SRCREV = "982f172262693198f649d4d8918e5defb1ff6c9c"
20
21SYSTEMD_SERVICE_${PN} = "attn_handler.service"
22
23DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
24           nlohmann-json"
25
26# This is required so that libhei is installed with the chip data files.
27RDEPENDS_${PN} += "openpower-libhei"
28
29# Conditionally pull in PHAL APIs, if available.
30PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
31PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata"
32
33