16714373fSZane ShelleySUMMARY = "Hardware Diagnostics for POWER Systems"
2fac997f3SBrad Bishop
36714373fSZane ShelleyDESCRIPTION = \
46714373fSZane Shelley    "In the event of a system fatal error reported by the internal system \
56714373fSZane Shelley    hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
66714373fSZane Shelley    POWER Systems have the ability to diagnose the root cause of the failure \
76714373fSZane Shelley    and perform any service action needed to avoid repeated system failures."
86714373fSZane Shelley
992804a7dSZane ShelleyHOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
1092804a7dSZane Shelley
11fac997f3SBrad BishopLICENSE = "Apache-2.0"
12fac997f3SBrad BishopLIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13fac997f3SBrad Bishop
1492804a7dSZane ShelleyPR = "r1"
1592804a7dSZane ShelleyPV = "0.1+git${SRCPV}"
16fac997f3SBrad Bishop
17bb99d22eSPatrick WilliamsSRC_URI = "git://github.com/openbmc/openpower-hw-diags;branch=master;protocol=https"
18*12e63a59SAndrew GeisslerSRCREV = "5137b2f5a43dbb466805f62971d3bf4105779f9f"
196714373fSZane Shelley
2092804a7dSZane ShelleyS = "${WORKDIR}/git"
2192804a7dSZane Shelley
22baf5ba7cSAndrew Geisslerinherit pkgconfig meson systemd
2392804a7dSZane Shelley
248c6707f0SAdriana KobylakSYSTEMD_SERVICE:${PN} = "attn_handler.service"
256714373fSZane Shelley
26b6d95eeeSZane ShelleyDEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
2775174d3cSZane Shelley           nlohmann-json valijson fmt"
28b6d95eeeSZane Shelley
298dff99bcSZane Shelley# This is required so that libhei is installed with the chip data files.
308c6707f0SAdriana KobylakRDEPENDS:${PN} += "openpower-libhei"
31aa8acf1bSZane Shelley
32aa8acf1bSZane Shelley# Conditionally pull in PHAL APIs, if available.
338c561eecSPatrick WilliamsPACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
342ded481fSBen TynerPACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, ipl pdata"
35aa8acf1bSZane Shelley
36896d1425SZane Shelley# Don't build CI tests
37896d1425SZane ShelleyEXTRA_OEMESON = "-Dtests=disabled"
38896d1425SZane Shelley
391a6eedc2SAndrew Geisslerpkg_postinst:${PN}() {
401a6eedc2SAndrew Geissler    mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
411a6eedc2SAndrew Geissler    LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/attn_handler.service"
421a6eedc2SAndrew Geissler    TARGET="../attn_handler.service"
431a6eedc2SAndrew Geissler    ln -s $TARGET $LINK
441a6eedc2SAndrew Geissler}
451a6eedc2SAndrew Geissler
461a6eedc2SAndrew Geisslerpkg_prerm:${PN}() {
471a6eedc2SAndrew Geissler    LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/attn_handler.service"
481a6eedc2SAndrew Geissler    rm $LINK
491a6eedc2SAndrew Geissler}
50