1SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-ipmiprovider-symlink
10inherit pythonnative
11
12require ${PN}.inc
13
14DEPENDS += "phosphor-ipmi-host"
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "sdbusplus sdbusplus-native"
17DEPENDS += "phosphor-logging"
18DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
19DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
20DEPENDS += "sdbus++-native"
21
22RDEPENDS_${PN} += " \
23        sdbusplus \
24        phosphor-logging \
25        openpower-dbus-interfaces \
26        phosphor-dbus-interfaces \
27        "
28
29TARGET_CFLAGS += "-fpic"
30
31HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
32
33S = "${WORKDIR}/git"
34
35FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
36FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
37FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
38