1SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol"
2HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash"
3PR = "r1"
4PV = "0.1+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58"
7
8inherit meson pkgconfig
9inherit obmc-phosphor-ipmiprovider-symlink
10
11DEPENDS += "phosphor-ipmi-host"
12DEPENDS += "sdbusplus"
13DEPENDS += "phosphor-logging"
14DEPENDS += "phosphor-dbus-interfaces"
15
16TARGET_CFLAGS += "-fpic"
17
18HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
19
20S = "${WORKDIR}/git"
21
22SRC_URI = "git://github.com/openbmc/openpower-host-ipmi-flash;branch=master;protocol=https"
23SRCREV = "564efaea8521f035c6a0c8c371121acec87027a6"
24
25EXTRA_OEMESON:append = " -Dtests=disabled"
26
27FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
28FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
29FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
30