1SUMMARY = "OpenPOWER Host checkstop monitor application"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit obmc-phosphor-systemd
7inherit allarch
8
9DEPENDS += "virtual/obmc-gpio-monitor"
10RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
11
12# For now, monitoring checkstop is the only usecase
13OBMC_HOST_MONITOR_INSTANCES = "checkstop"
14
15# Copies config file having arguments for monitoring host checkstop
16# via GPIO assertion
17SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
18
19# This package is not supplying the unit file and also this is not a native
20# recipe since state-mgmt needs this package at runtime. Unsetting this below
21# variable will let the build go through
22SYSTEMD_SERVICE_${PN} ?=""
23
24# Install the override to set up a Conflicts relation
25SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
26
27STATES = "startmin"
28GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
29GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
30CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
31SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
32