1HOMEPAGE =  "https://github.com/open-power/ipl/"
2
3SUMMARY     = "Initial Program Load steps"
4DESCRIPTION = "Provides infrastructure to run istep"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10inherit autotools pkgconfig
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://git@github.com/open-power/ipl;branch="main";protocol=https"
15SRCREV = "75b471c171b444e4daa9ec867e7e233f339149c4"
16
17DEPENDS = " \
18        libekb pdbg autoconf-archive guard pdata \
19        "
20
21RDEPENDS:${PN} = "phal-devtree"
22
23EXTRA_OECONF = "CHIP=p10 --enable-libphal"
24