1HOMEPAGE =  "https://github.com/open-power/guard"
2SUMMARY     = "Guard the faulty components"
3DESCRIPTION = "Provide a way to guard the faulty component from the system"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit pkgconfig meson
10
11S = "${WORKDIR}/git"
12
13SRC_URI = "git://git@github.com/open-power/guard;branch="main";protocol=https"
14SRCREV = "e000b571c82e854180ddcbda3b76754341c72618"
15
16DEPENDS = "cli11"
17
18PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
19PACKAGECONFIG[phal] = "-Ddevtree=enabled, -Ddevtree=disabled, pdata pdbg"
20