1SUMMARY = "Xfce4 Widget library and X Window System interaction"
2SECTION = "x11/libs"
3LICENSE = "LGPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4cf66a4984120007c9881cc871cf49db"
5DEPENDS = "intltool-native perl-native gtk+3 libxfce4util xfce4-dev-tools xfconf"
6
7inherit xfce gtk-doc gobject-introspection features_check
8
9# xfce4 depends on libwnck3. gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
10# cairo would at least needed to be built with xlib.
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12
13# TODO: Check if 0001-... can go
14SRC_URI += "file://0001-libxfce4kbd-private-xfce4-keyboard-shortcuts.xml-fix.patch"
15SRC_URI[sha256sum] = "16815eef494ba9bac9c854e95c205c0bc5568c8022c31604348f9edadb02f227"
16
17EXTRA_OECONF += "--with-vendor-info=${DISTRO}"
18EXTRA_OECONF += "--disable-vala"
19
20PACKAGECONFIG ??= " \
21       ${@bb.utils.contains('DISTRO_FEATURES', 'opengl','x11', "", d)} \
22"
23PACKAGECONFIG[gladeui2] = "--enable-gladeui2,--disable-gladeui2,glade"
24PACKAGECONFIG[x11] = "--enable-startup-notification,--disable-startup-notification,libepoxy libice libsm startup-notification"
25
26
27PACKAGES += "${PN}-glade"
28FILES:${PN}-glade = " \
29    ${libdir}/glade \
30    ${datadir}/glade \
31"
32