1DESCRIPTION = "Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+3 libxfce4ui liburi-perl-native cairo"
6
7inherit xfce perlnative gtk-doc features_check mime-xdg
8
9# xfce4 depends on libwnck3, gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
10# cairo would at least needed to be built with xlib.
11ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
12
13# SRC_URI must follow inherited one
14SRC_URI += " \
15    file://exo-no-tests-0.8.patch \
16"
17
18SRC_URI[sha256sum] = "a0124108c197efcc576a6deeface381416dc7137b6a7e7dfa3060fad62509fb7"
19
20# Note: python bindings did not work in oe-dev and are about to be moved to
21# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
22FILES:${PN} += " \
23    ${datadir}/xfce4/ \
24    ${libdir}/xfce4/exo* \
25"
26