1SUMMARY = "X11 Mouse Theme"
2HOMEPAGE = "http://xfce-look.org/content/show.php/OpenZone?content=111343"
3SECTION = "x11/wm"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a2f562fb8fb1e138b810d69521c4bcd7"
6
7inherit allarch gtk-icon-cache
8
9SRC_URI = "http://xfce-look.org/CONTENT/content-files/111343-OpenZone-${PV}.tar.xz"
10SRC_URI[md5sum] = "4dae968cbd525072664ef7a4fc7c4154"
11SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d339efd92"
12
13S = "${WORKDIR}/OpenZone"
14
15do_compile() {
16}
17
18do_install() {
19    install -d ${D}${datadir}/icons
20    for theme in `find -name '*.tar.xz'`; do
21        tar -Jxf ${theme} -C ${D}${datadir}/icons
22    done
23}
24
25python populate_packages:prepend () {
26    icondir = bb.data.expand('${datadir}/icons', d)
27    do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
28}
29
30FILES:${PN} += "${datadir}/icons"
31
32PACKAGES_DYNAMIC += "^openzone-.*"
33ALLOW_EMPTY:${PN} = "1"
34