1SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "https://docs.xfce.org/apps/notifyd/start"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6DEPENDS = " \
7    glib-2.0-native \
8    libnotify \
9    libxfce4util \
10    libxfce4ui \
11    xfconf \
12    xfce4-panel \
13"
14
15inherit xfce-app
16
17SRC_URI:append = " file://xfce4-notifyd-get-var-abs-path.patch"
18
19SRC_URI[sha256sum] = "e3a28adb08daa1411135142a0d421e4d6050c4035a4e513a673a59460ff2ae84"
20
21# Avoid trouble with other desktops e.g KDE which also ships dbus service named
22# org.freedesktop.Notifications
23EXTRA_OECONF = "--disable-dbus-start-daemon"
24
25do_compile:prepend() {
26    mkdir -p xfce4-notifyd xfce4-notifyd-config
27}
28
29FILES:${PN} += " \
30    ${systemd_user_unitdir} \
31    ${datadir}/xfce4 \
32    ${datadir}/themes \
33    ${datadir}/dbus-1 \
34    ${libdir}/xfce4 \
35"
36