1*8fc454f9SAndrew GeisslerSUMMARY = "FastCGI wrapper for CGI scripts"
2*8fc454f9SAndrew GeisslerDESCRIPTION = "FcgiWrap is a simple server for running CGI applications over FastCGI. Fcgiwrap can be used together with Nginx to serve CGI or Perl scripts"
3*8fc454f9SAndrew GeisslerHOMEPAGE = "https://github.com/gnosek/fcgiwrap"
4*8fc454f9SAndrew Geissler
5*8fc454f9SAndrew GeisslerLICENSE = "MIT"
6*8fc454f9SAndrew GeisslerLIC_FILES_CHKSUM = "file://COPYING;md5=a95d02d614a3a0232d4e6e51b7963c5b"
7*8fc454f9SAndrew Geissler
8*8fc454f9SAndrew GeisslerDEPENDS = "fcgi"
9*8fc454f9SAndrew Geissler
10*8fc454f9SAndrew GeisslerSRC_URI = "git://github.com/gnosek/fcgiwrap.git;protocol=https;branch=${BRANCH} \
11*8fc454f9SAndrew Geissler           file://0001-Fix-implicit-fallthrough-warning.patch \
12*8fc454f9SAndrew Geissler           "
13*8fc454f9SAndrew GeisslerBRANCH = "master"
14*8fc454f9SAndrew GeisslerSRCREV = "99c942c90063c73734e56bacaa65f947772d9186"
15*8fc454f9SAndrew Geissler
16*8fc454f9SAndrew GeisslerS = "${WORKDIR}/git"
17*8fc454f9SAndrew GeisslerCFLAGS =+ "-I${B}"
18*8fc454f9SAndrew GeisslerEXTRA_OEMAKE = "VPATH=${S}"
19*8fc454f9SAndrew Geissler
20*8fc454f9SAndrew Geisslerinherit autotools pkgconfig
21*8fc454f9SAndrew Geissler
22*8fc454f9SAndrew Geisslerdo_install() {
23*8fc454f9SAndrew Geissler    install -Dm 755 ${B}/fcgiwrap ${D}${sbindir}/fcgiwrap
24*8fc454f9SAndrew Geissler}
25