1SUMMARY = "A simple, small, portable, fast, and secure HTTP server"
2DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server (supported fork of thttpd)."
3HOMEPAGE = "http://opensource.dyc.edu/sthttpd"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://src/thttpd.c;beginline=1;endline=26;md5=0c5762c2c34dcbe9eb18815516502872"
6
7DEPENDS += "base-passwd virtual/crypt"
8
9SRCREV = "2845bf5bff2b820d2336c8c8061cbfc5f271e720"
10SRC_URI = "git://github.com/blueness/${BPN};branch=master;protocol=https \
11           file://0001-Define-_GNU_SOURCE-if-HAVE_SIGSET-is-set.patch \
12           file://thttpd.service \
13           file://thttpd.conf \
14           file://init"
15
16UPSTREAM_CHECK_URI = "https://github.com/blueness/sthttpd/releases/"
17UPSTREAM_CHECK_REGEX = "v(?P<pver>\d+(\.\d+)+).tar.gz"
18
19S = "${WORKDIR}/git"
20
21inherit autotools update-rc.d systemd update-alternatives
22
23ALTERNATIVE_PRIORITY = "100"
24ALTERNATIVE:${PN}-doc = "htpasswd.1"
25ALTERNATIVE_LINK_NAME[htpasswd.1] = "${mandir}/man1/htpasswd.1"
26
27SRV_DIR ?= "${servicedir}/www"
28
29# Note that `${sbindir}/makeweb' is installed setgid to this group,
30# but ${SRV_DIR} is not installed chgrp'd to the group by default.
31WEBGROUP ?= "www-data"
32
33do_configure:prepend () {
34    export WEBDIR=${SRV_DIR}
35    export WEBGROUP=${WEBGROUP}
36}
37
38do_install:append () {
39    install -d ${D}${sysconfdir}/init.d
40    install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
41    install -c -m 755 ${WORKDIR}/thttpd.conf ${D}${sysconfdir}
42    sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${sysconfdir}/init.d/thttpd
43    sed -i -e 's,@@SRVDIR,${SRV_DIR},g' ${D}${sysconfdir}/thttpd.conf
44    sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd
45
46    install -d ${D}${systemd_unitdir}/system
47    install -m 0644 ${WORKDIR}/thttpd.service ${D}${systemd_unitdir}/system
48    sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
49    sed -i 's!/var/!${localstatedir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
50    sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${systemd_unitdir}/system/thttpd.service
51}
52
53INITSCRIPT_NAME = "thttpd"
54INITSCRIPT_PARAMS = "defaults"
55
56SYSTEMD_SERVICE:${PN} = "thttpd.service"
57
58FILES:${PN} += "${SRV_DIR}"
59FILES:${PN}-dbg += "${SRV_DIR}/cgi-bin/.debug"
60