1SUMMARY = "Provides a wrapper in Python to LDAP"
2DESCRIPTION = "This module provides access to the LDAP \
3(Lightweight Directory Access Protocol) through Python operations \
4instead of C API. The module mainly acts as a wrapper for the \
5OpenLDAP 2.x libraries. Errors will appear as exceptions."
6HOMEPAGE = "http://www.python-ldap.org/"
7LICENSE = "PSF-2.0"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
9
10DEPENDS = "python3 openldap cyrus-sasl"
11
12PYPI_PACKAGE = "python-ldap"
13
14inherit pypi setuptools3
15
16SRC_URI[sha256sum] = "7edb0accec4e037797705f3a05cbf36a9fde50d08c8f67f2aef99a2628fab828"
17
18do_configure:prepend() {
19    sed -i -e 's:^library_dirs =.*::' \
20        -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' \
21        -e 's/= ldap_r/= ldap/g' ${S}/setup.cfg
22}
23
24RDEPENDS:${PN} = " \
25    python3-pprint \
26    python3-pyasn1 \
27    python3-pyasn1-modules \
28    python3-threading \
29    python3-unittest \
30"
31