1SUMMARY = "Cross-platform locking library"
2DESCRIPTION = "Portalocker is a library to provide an easy API to file locking"
3LICENSE = "BSD-3-Clause"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=152634da660a374ca18c0734ed07c63c"
6
7SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25ee4f33"
8
9DEPENDS += "python3-setuptools-scm-native"
10
11inherit pypi python_setuptools_build_meta ptest
12
13SRC_URI += " \
14	file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18	python3-multiprocessing \
19	python3-pytest \
20	python3-redis \
21	python3-unittest-automake-output \
22	redis \
23"
24
25do_install_ptest() {
26	install -d ${D}${PTEST_PATH}/tests
27	cp -rf ${S}/portalocker_tests/* ${D}${PTEST_PATH}/tests/
28	rm -rf ${D}${PTEST_PATH}/tests/test_combined.py
29}
30
31RDEPENDS:${PN} += " \
32	python3-fcntl \
33	python3-logging \
34"
35
36BBCLASSEXTEND = "native nativesdk"
37