1DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
2an interface to libparted, the GNU parted library for disk partitioning and \
3filesystem manipulation."
4SUMMARY = "Python bindings for libparted"
5HOMEPAGE = "https://github.com/rhinstaller/pyparted"
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "\
8    file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
9    file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
10"
11
12SRC_URI[sha256sum] = "da985e116beb733371feb605b174db9eec8bd0eedffc8f739f8e603f51b521e7"
13
14inherit pkgconfig pypi setuptools3
15
16DEPENDS += "parted"
17
18RDEPENDS:${PN}:class-target += " \
19    parted (>= 2.3) \
20    python3-codecs \
21    python3-math \
22    python3-numbers \
23    python3-stringold \
24"
25RDEPENDS:${PN}:class-native = ""
26
27BBCLASSEXTEND = "native"
28