1DESCRIPTION = "A python library for manipulating kickstart files"
2HOMEPAGE = "http://fedoraproject.org/wiki/pykickstart"
3LICENSE = "GPL-2.0-or-later"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
6FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
7
8DEPENDS = "python3"
9RDEPENDS:${PN} = "python3 \
10                  python3-requests \
11                  python3-six \
12"
13
14S = "${WORKDIR}/git"
15SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \
16           file://0001-support-authentication-for-kickstart.patch \
17           file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \
18           file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \
19           file://0004-load.py-retry-to-invoke-request-with-timeout.patch \
20           "
21SRCREV = "fa6c80c0e5c6bee29d089899a10d26e6f7f8afd8"
22
23UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
24
25inherit setuptools3
26PIP_INSTALL_PACKAGE = "pykickstart"
27PIP_INSTALL_DIST_PATH = "${S}/dist"
28