1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Python library for CSON (schema-compressed JSON)"
5HOMEPAGE = "https://github.com/gt3389b/python-cson/"
6LICENSE = "MIT"
7SECTION = "devel/python"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
9
10PV = "1.0.9+1.0.10"
11SRCREV = "69090778bccc5ed124342ba288597fbb2bfa9f39"
12SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https \
13           file://0001-setup.py-Do-not-poke-at-git-describe-to-find-version.patch"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS:${PN} = "python3-json"
18
19inherit setuptools3
20
21PIP_INSTALL_PACKAGE = "python_cson"
22
23do_configure:prepend() {
24    echo "__version__=${PV}" > ${S}/version.py
25}
26
27BBCLASSEXTEND = "native"
28
29