1SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI[sha256sum] = "566db86717cf8080b99b58b083b773a908ae40f06681e87e589a976faf8246bf"
7
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest python_setuptools_build_meta
13
14DEPENDS += " \
15    python3-expandvars-native \
16    python3-cython-native \
17"
18
19RDEPENDS:${PN} = "\
20    python3-multidict \
21    python3-idna \
22    python3-io \
23"
24
25RDEPENDS:${PN}-ptest += " \
26    python3-pytest \
27    python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31    install -d ${D}${PTEST_PATH}/tests
32    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}
34