1SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6SRC_URI[sha256sum] = "20d95535e7d833889982bfe7cc321b7f63bf8879788fee982c76ae2b24cfb715"
7
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest python_setuptools_build_meta cython
13
14DEPENDS += " \
15    python3-expandvars-native \
16"
17
18RDEPENDS:${PN} = "\
19    python3-multidict \
20    python3-idna \
21    python3-io \
22    python3-propcache \
23"
24
25RDEPENDS:${PN}-ptest += " \
26    python3-hypothesis \
27    python3-image \
28    python3-pytest \
29    python3-pytest-codspeed \
30    python3-rich \
31    python3-unittest-automake-output \
32"
33
34do_install_ptest() {
35    install -d ${D}${PTEST_PATH}/tests
36    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
37}
38