1SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
2DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\
3 versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \
4Strong support for Excel dates. Unicode-aware."
5HOMEPAGE = "http://www.python-excel.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=00ea1e843a43c20d9b63a8112239b0d1"
8
9SRC_URI[sha256sum] = "f72f148f54442c6b056bf931dbc34f986fd0c3b0b6b5a58d013c9aef274d0c88"
10
11
12SRC_URI = "git://github.com/python-excel/xlrd.git;branch=master;protocol=https \
13           file://run-ptest \
14"
15SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
16
17S = "${WORKDIR}/git"
18
19inherit ptest setuptools3
20PIP_INSTALL_PACKAGE = "xlrd"
21PIP_INSTALL_DIST_PATH = "${S}/dist"
22
23RDEPENDS:${PN} += " \
24    python3-compression \
25    python3-io \
26    python3-mmap \
27    python3-pprint \
28    python3-shell \
29"
30
31RDEPENDS:${PN}-ptest += " \
32    python3-pytest \
33"
34
35do_install_ptest() {
36    install -d ${D}${PTEST_PATH}/tests
37    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
38}
39
40BBCLASSEXTEND = "native nativesdk"
41