1SUMMARY = "Unified diff parsing/metadata extraction library"
2HOMEPAGE = "http://github.com/matiasb/python-unidiff"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
5
6SRC_URI[sha256sum] = "2e5f0162052248946b9f0970a40e9e124236bf86c82b70821143a6fc1dea2574"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11        file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15       python3-pytest \
16       python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20      install -d ${D}${PTEST_PATH}/tests
21        cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += " \
25    python3-codecs \
26    python3-io \
27"
28