1SUMMARY = "Various data structures and parsing tools for UEFI firmware."
2DESCRIPTION = "This package contains Python UEFI firmware parser tool. The \
3UEFI firmware parser is a simple module and set of scripts for parsing, \
4extracting, and recreating UEFI firmware volumes. This includes parsing \
5modules for BIOS, OptionROM, Intel ME and other formats too."
6HOMEPAGE = "https://github.com/theopolis/uefi-firmware-parser"
7LICENSE = "BSD-2-Clause & BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://setup.py;md5=5a59066a8676f17262ef7e691f8ef253"
9
10SRC_URI = "git://github.com/theopolis/uefi-firmware-parser;protocol=https;branch=master"
11
12SRCREV = "f289219b99eb525cbc58e4dc2b07df3811f92ef7"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18RDEPENDS:${PN} += " \
19    python3-ctypes \
20    python3-logging \
21"
22