1# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Automate and standardize testing in Python. It is part of a larger vision of easing the packaging, testing and release process of Python software (alongside pytest and devpi)."
5HOMEPAGE = "http://tox.readthedocs.org/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
8
9SRC_URI[sha256sum] = "0defb44f6dafd911b61788325741cc6b2e12ea71f987ac025ad4d649f1f1a104"
10
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15    python3-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += "\
19    python3-cachetools \
20    python3-chardet \
21    python3-colorama \
22    python3-filelock \
23    python3-packaging \
24    python3-platformdirs \
25    python3-pluggy \
26    python3-pyproject-api \
27    python3-tomli \
28    python3-virtualenv \
29"
30
31# Install all built-in python3 modules, as the software tested with tox might
32# depend on it. Tox will attempt to install all required dependencies
33# in a virtualenv using pip, but this obviously does not include the built-in modules.
34RDEPENDS:${PN} += "python3-modules"
35