1SUMMARY = "CSS selector library for python-beautifulsoup4"
2HOMEPAGE = "https://github.com/facelessuser/soupsieve"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=520586fa71ed2cbda50b4a8c89621e09"
6
7SRC_URI[sha256sum] = "5663d5a7b3bfaeee0bc4372e7fc48f9cff4940b3eec54a6451cc5299f1097690"
8
9inherit pypi python_hatchling python_setuptools_build_meta ptest
10
11SRC_URI += " \
12        file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16        ${PYTHON_PN}-pytest \
17        ${PYTHON_PN}-beautifulsoup4 \
18"
19
20do_install_ptest() {
21        install -d ${D}${PTEST_PATH}/tests
22        cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25BBCLASSEXTEND = "native nativesdk"
26