1DESCRIPTION = "Python module for Semantic Versioning"
2HOMEPAGE = "https://github.com/python-semver/python-semver"
3BUGTRACKER = "https://github.com/python-semver/python-semver"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d9da679db3bdce30a1b4328d5c474f98"
6
7SRC_URI[sha256sum] = "6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc"
8
9inherit pypi python_setuptools_build_meta ptest
10
11BBCLASSEXTEND = "native nativesdk"
12
13SRC_URI += " \
14        file://run-ptest \
15"
16
17DEPENDS += " python3-setuptools-scm-native"
18
19RDEPENDS:${PN}-ptest += " \
20    python3-pytest \
21    python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25        cp -rf ${S}/tests ${D}${PTEST_PATH}/
26}
27