1HOMEPAGE = "https://github.com/bb4242/sdnotify"
2SUMMARY = "A pure Python implementation of systemd's service notification protocol (sd_notify)"
3
4DESCRIPTION = "\
5  sdnotify is a pure Python implementation of the systemd sd_notify protocol. \
6  This protocol can be used to inform systemd about service start-up completion, \
7  watchdog events, and other service status changes. \
8  Thus, this package can be used to write system services in Python that play nicely with systemd. \
9  "
10
11SECTION = "devel/python"
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e"
14
15SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1"
16
17SRC_URI += "file://0001-setup.py-switch-to-setuptools.patch"
18
19inherit setuptools3 pypi
20
21RDEPENDS:${PN} += "python3-io"
22