1DESCRIPTION = "A utility belt for advanced users of python-requests."
2HOMEPAGE = "https://toolbelt.readthedocs.org"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075"
6
7SRC_URI = "file://run-ptest \
8	   file://090856f4159c40a2927fb88546419f2e1697ad5f.patch \
9	   file://720240501dca0b4eacc3295665d7ced8719e11d2.patch \
10          "
11
12SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c88d5bc6"
13
14inherit pypi setuptools3 ptest
15
16RDEPENDS:${PN} += " \
17    python3-requests (>=2.0.1) \
18"
19
20RDEPENDS:${PN}-ptest += " \
21    python3-betamax \
22    python3-mock \
23    python3-multiprocessing \
24    python3-pytest \
25    python3-trustme \
26    python3-unittest-automake-output \
27"
28
29do_install_ptest() {
30	install -d ${D}${PTEST_PATH}/tests
31	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32	cp -rf ${S}/setup.py ${D}${PTEST_PATH}
33	# remove test test_multipart_encoder.py as it fails,
34	# downloaded file is not supported
35	rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py
36}
37