1SUMMARY = "A generator framework based on a common modern IDL"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=eee61e10a40b0e3045ee5965bcd9a8b5"
4
5SRC_URI[sha256sum] = "eccee7dbc4290c5a4e394df8d527f39148e0de0ff22c6b260f48c48f12b3beb4"
6
7inherit pypi setuptools3
8
9DEPS = "\
10    python3-jinja2 \
11    python3-click \
12    python3-pyyaml \
13    python3-pytest \
14    python3-six \
15    python3-path \
16    python3-antlr4-runtime \
17    python3-watchdog \
18    python3-markupsafe \
19    python3-setuptools \
20"
21DEPENDS += "${DEPS}"
22RDEPENDS:${PN} += "${DEPS}"
23
24BBCLASSEXTEND = "nativesdk native"
25