1SUMMARY = "PyZMQ: Python bindings for ZMQ"
2DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
3HOMEPAGE = "http://zeromq.org/bindings:python"
4LICENSE = "BSD-3-Clause & LGPL-3.0-only"
5LIC_FILES_CHKSUM = "\
6    file://LICENSE.BSD;md5=1787206f198344195a671b60326c59dc \
7    file://LICENSE.LESSER;md5=0e99bfbdd8b9d33b0221986fe3be89ed \
8"
9
10DEPENDS = "python3-packaging-native python3-cython-native python3-setuptools-scm-native zeromq"
11
12SRC_URI:append = " \
13    file://club-rpath-out.patch \
14    file://run-ptest \
15"
16SRC_URI[sha256sum] = "93f1aa311e8bb912e34f004cf186407a4e90eec4f0ecc0efd26056bf7eda0226"
17
18inherit pypi pkgconfig python_setuptools_build_meta ptest
19
20PACKAGES =+ "\
21    ${PN}-test \
22"
23
24FILES:${PN}-test += "\
25    ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
26"
27
28RDEPENDS:${PN} += "\
29        python3-json \
30        python3-multiprocessing \
31"
32
33RDEPENDS:${PN}-ptest += "\
34    ${PN}-test \
35    python3-pytest \
36    python3-unittest-automake-output \
37    python3-unixadmin \
38"
39
40do_compile:prepend() {
41    echo [global] > ${S}/setup.cfg
42    echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg
43    echo have_sys_un_h = True >> ${S}/setup.cfg
44    echo skip_check_zmq = True >> ${S}/setup.cfg
45    echo libzmq_extension = False >> ${S}/setup.cfg
46    echo no_libzmq_extension = True >> ${S}/setup.cfg
47}
48
49do_install:append() {
50        sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json
51        sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json
52}
53
54do_install_ptest() {
55        install -d ${D}${PTEST_PATH}/tests
56        cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
57}
58