1SUMMARY = "Extending PyYAML with a custom constructor for including YAML files within YAML files"
2HOMEPAGE = "https://github.com/tanbro/pyyaml-include"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS += "python3-setuptools-scm-native"
6SRCREV = "36b6975aa8fc7a6cbf37de40aa2ed6d996b2f7be"
7
8SRC_URI = " \
9            git://github.com/tanbro/pyyaml-include;protocol=https;branch=main \
10            file://run-ptest \
11          "
12
13S = "${WORKDIR}/git"
14
15inherit python_setuptools_build_meta ptest
16
17do_install_ptest() {
18    install -d ${D}${PTEST_PATH}/tests
19    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
20}
21
22RDEPENDS:${PN} += " \
23    python3-pyyaml \
24"
25RDEPENDS:${PN}-ptest += " \
26    python3-pytest \
27    python3-unittest-automake-output \
28"
29
30