1SUMMARY = "PyUSB provides USB access on the Python language"
2HOMEPAGE = "http://pyusb.sourceforge.net/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e64a29fcd3c3dd356a24e235dfcb3905"
5
6DEPENDS += "libusb1 python3-setuptools-scm-native"
7
8RDEPENDS:${PN} += " \
9	python3-logging \
10"
11
12SRC_URI[sha256sum] = "a4cc7404a203144754164b8b40994e2849fde1cfff06b08492f12fff9d9de7b9"
13
14inherit pypi setuptools3
15
16RDEPENDS:${PN} += "python3-ctypes"
17
18BBCLASSEXTEND = "native nativesdk"
19