1SUMMARY = "pytest xdist plugin for distributed testing and loop-on-failing modes"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-xdist"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
5
6SRC_URI[sha256sum] = "cbb36f3d67e0c478baa57fa4edc8843887e0f6cfc42d677530a36d7472b32d8a"
7
8inherit pypi python_setuptools_build_meta
9
10DEPENDS += "python3-setuptools-scm-native"
11
12# Note that the dependency on pytest-forked is scheduled to be dropped in 3.0
13RDEPENDS:${PN} += " \
14    python3-execnet \
15    python3-pytest \
16    python3-pytest-forked \
17"
18