1SUMMARY = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPL-2.0-or-later | Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dccbff78d7d79ae7e53953d43445c6e6 \
4                    file://LICENSE.GPL-2.0-or-later;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5                    file://LICENSE.Apache-2.0;md5=34281e312165f843a2b7d1f114fe65ce"
6
7SRC_URI[sha256sum] = "cc2f90aad1517cb0b301041f678cc8d3c3427c26e53f15c78c93c67928d89a02"
8
9inherit setuptools3 pypi ptest
10
11RDEPENDS:${PN} += " \
12    python3-ctypes \
13    python3-io \
14    python3-json \
15    python3-fcntl \
16    python3-logging \
17    python3-multiprocessing \
18    python3-pickle \
19    python3-pkgutil \
20    python3-pprint \
21    python3-shell \
22    python3-unixadmin \
23"
24
25SRC_URI += " \
26    file://run-ptest \
27"
28
29RDEPENDS:${PN}-ptest += " \
30    python3-pytest \
31    python3-fcntl \
32    python3-sqlite3 \
33"
34
35do_install_ptest() {
36    install -d ${D}${PTEST_PATH}/tests
37    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
38    sed -e  "s|'test_unit|'tests/test_unit|g" -i  ${D}${PTEST_PATH}/tests/test_unit/test_nlmsg/test_marshal.py \
39    ${D}${PTEST_PATH}/tests/test_unit/test_iproute_match/test_match.py
40}
41