1SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "44aa7c704c2b7d8fb3d483bbf75af6cb2350d30a63b144279a09b75fead501bf"
12
13RDEPENDS:${PN} = " \
14    python3-certifi \
15    python3-compression \
16    python3-json \
17    python3-logging \
18    python3-profile \
19"
20
21export PROJ_INCDIR = "${STAGING_INCDIR}"
22export PROJ_LIBDIR = "${STAGING_LIBDIR}"
23export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."
24