1SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5    * Simple API to run reliable benchmarks \
6    * Automatically calibrate a benchmark for a time budget. \
7    * Spawn multiple worker processes. \
8    * Compute the mean and standard deviation. \
9    * Detect if a benchmark result seems unstable. \
10    * JSON format to store benchmark results. \
11    * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
16SRC_URI[sha256sum] = "9752fe749c21e460a564bb3f52fc319b892c62ee61c5138b4a9bbf94ad2755e6"
17
18DEPENDS += "python3-six-native"
19
20PYPI_PACKAGE = "pyperf"
21inherit pypi python_setuptools_build_meta
22
23RDEPENDS:${PN} += "python3-misc python3-statistics"
24