1SUMMARY = "Linux network configuration library for Python"
2DESCRIPTION = "This library contains Python bindings to ioctl calls"
3SECTION = "devel/python"
4HOMEPAGE = "http://github.com/rlisagor/pynetlinux"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=74e1861736ee959824fe7542323c12e9"
7
8SRC_URI[sha256sum] = "4ad08298c9f5ba15a11cddc639ba8778cabdfc402b51066d9e0a325e5a5b391c"
9
10SRC_URI += " \
11    file://0001-setup.py-switch-to-setuptools.patch \
12    file://0002-Fixed-relative-imports.patch \
13"
14
15inherit pypi setuptools3
16
17RDEPENDS:${PN} += " \
18    python3-ctypes \
19    python3-fcntl \
20    python3-io \
21"
22