1SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
3HOMEPAGE = "https://github.com/pyca/pynacl"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
6
7SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
8
9PYPI_PACKAGE = "PyNaCl"
10
11inherit pypi python_setuptools_build_meta
12
13DEPENDS += "\
14    ${PYTHON_PN}-cffi-native \
15    libsodium \
16"
17
18RDEPENDS:${PN} = "\
19    ${PYTHON_PN}-six \
20    ${PYTHON_PN}-cffi \
21    libsodium \
22"
23
24do_compile:prepend() {
25    export SODIUM_INSTALL=system
26}
27
28do_install:prepend() {
29    export SODIUM_INSTALL=system
30}
31