1SUMMARY = "A pure-Python MySQL client library"
2DESCRIPTION = " \
3  This package contains a pure-Python MySQL client library, based on PEP 249 \
4  Most public APIs are compatible with mysqlclient and MySQLdb. \
5  "
6SECTION = "devel/python"
7HOMEPAGE = "https://pymysql.readthedocs.io"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
10
11SRC_URI[sha256sum] = "4f13a7df8bf36a51e81dd9f3605fede45a4878fe02f9236349fd82a3f0612f96"
12
13PYPI_PACKAGE = "PyMySQL"
14inherit pypi python_setuptools_build_meta
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pymysql/"
17UPSTREAM_CHECK_REGEX = "/pymysql/(?P<pver>(\d+[\.\-_]*)+)"
18
19RDEPENDS:${PN} += "python3-cryptography"
20