1SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=eba8057aa82c058d2042b4b0a0e9cc63"
5
6SRC_URI[sha256sum] = "c4d556a0954d00a9e1c8f1d0de03f41c4800336e6d785e820f2917eeb4ee7736"
7
8inherit pypi python_setuptools_build_meta
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
12PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
13PACKAGECONFIG[tornado] = ",,,python3-tornado"
14PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
15PACKAGECONFIG[redis] = ",,,python3-redis"
16PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
17
18RDEPENDS:${PN} += " \
19    python3-asyncio \
20    python3-core \
21    python3-io \
22    python3-json \
23    python3-logging \
24    python3-math \
25    python3-netserver \
26"
27
28RDEPENDS:${PN} += " \
29    python3-pyserial \
30    python3-six \
31"
32