1SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.1.x;protocol=https \
7           file://0001-Adjust-test-expectations-for-ptest.patch \
8           file://run-ptest \
9           "
10SRCREV = "053c2c3a25f97f043e10cdd41d2609e495a68f57"
11
12inherit python_setuptools_build_meta ptest
13
14RDEPENDS:${PN} += "\
15    python3-astroid \
16    python3-difflib \
17    python3-dill \
18    python3-isort \
19    python3-json \
20    python3-mccabe \
21    python3-netserver \
22    python3-numbers \
23    python3-pkgutil \
24    python3-platformdirs \
25    python3-shell \
26    python3-tomlkit \
27    "
28
29RDEPENDS:${PN}-ptest += " \
30    python3-core \
31    python3-git \
32    python3-py \
33    python3-pytest \
34    python3-pytest-benchmark \
35    python3-pytest-runner \
36    python3-pytest-timeout \
37    python3-pytest-xdist \
38    python3-requests \
39    python3-statistics \
40    python3-tomllib \
41    python3-typing-extensions \
42    python3-unittest-automake-output \
43    "
44
45S = "${WORKDIR}/git"
46
47do_install_ptest() {
48    install -d ${D}${PTEST_PATH}/tests
49    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
50    install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
51    sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
52    # regression_distutil_import_error_73.py fails to run see
53    # https://lists.openembedded.org/g/openembedded-devel/topic/103181847
54    rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
55}
56
57BBCLASSEXTEND = "native nativesdk"
58