1SUMMARY = "Pure-Python Java Keystore (JKS) library"
2DESCRIPTION = "PyJKS enables Python projects to load and manipulate\
3 Java KeyStore (JKS) data without a JVM dependency. PyJKS supports JKS,\
4 JCEKS, BKS and UBER (BouncyCastle) keystores."
5HOMEPAGE = "http://github.com/kurtbrose/pyjks"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=9694d6cc724caf7f7386be88a4a81958"
8
9SRC_URI[md5sum] = "1a6bce95484f1f62f8ff59755972c632"
10SRC_URI[sha256sum] = "0378cec15fb11b2ed27ba54dad9fd987d48e6f62f49fcff138f5f7a8b312b044"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} = " \
15    python3-javaobj-py3 \
16    python3-pyasn1 \
17    python3-pyasn1-modules \
18    python3-pycryptodomex \
19    python3-twofish \
20"
21
22BBCLASSEXTEND = "native nativesdk"
23