1DESCRIPTION = "Pythonic DBus library"
2HOMEPAGE = "https://pypi.python.org/pypi/pydbus/"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a916467b91076e631dd8edb7424769c7"
5
6SRC_URI += "file://0001-Support-asynchronous-calls-58.patch \
7            file://0002-Support-transformation-between-D-Bus-errors-and-exce.patch \
8"
9
10SRC_URI[md5sum] = "c6abd44862322679bd4e907bebc3e0d0"
11SRC_URI[sha256sum] = "4207162eff54223822c185da06c1ba8a34137a9602f3da5a528eedf3f78d0f2c"
12
13inherit pypi setuptools3
14
15S = "${WORKDIR}/pydbus-${PV}"
16
17RDEPENDS:${PN} = "${PYTHON_PN}-pygobject \
18                  ${PYTHON_PN}-io \
19                  ${PYTHON_PN}-logging"
20