1DESCRIPTION = "Pythonic DBus library"
2HOMEPAGE = "https://pypi.python.org/pypi/pydbus/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a916467b91076e631dd8edb7424769c7"
5
6SRCREV = "f2e6355a88351e7d644ccb2b4d67b19305507312"
7SRC_URI = " \
8    git://github.com/LEW21/pydbus.git;protocol=https;branch=master \
9    file://0001-make-direction-attribute-conforming-to-introspect.dt.patch \
10    file://0002-Support-asynchronous-calls-58.patch \
11    file://0003-Support-transformation-between-D-Bus-errors-and-exce.patch \
12    file://run-ptest \
13"
14
15inherit ptest setuptools3
16
17S = "${WORKDIR}/git"
18
19RDEPENDS:${PN} = "python3-pygobject \
20                  python3-io \
21                  python3-logging"
22
23RDEPENDS:${PN}-ptest += "bash"
24
25do_install_ptest() {
26        install -d ${D}${PTEST_PATH}/tests
27        cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29