1SUMMARY = "Run a subprocess in a pseudo terminal"
2HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
6
7SRCNAME = "ptyprocess"
8
9SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
10
11inherit pypi python_flit_core
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17RDEPENDS:${PN} = "\
18    ${PYTHON_PN}-core \
19    ${PYTHON_PN}-fcntl \
20    ${PYTHON_PN}-terminal \
21    ${PYTHON_PN}-resource \
22"
23
24BBCLASSEXTEND = "native nativesdk"
25
26inherit ptest
27
28SRC_URI += " \
29	file://run-ptest \
30"
31
32RDEPENDS:${PN}-ptest += " \
33	${PYTHON_PN}-pytest \
34	${PYTHON_PN}-fcntl \
35	${PYTHON_PN}-terminal \
36	${PYTHON_PN}-resource \
37	bash \
38"
39
40do_install_ptest() {
41	install -d ${D}${PTEST_PATH}/tests
42	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
43}
44