1DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
7
8inherit pypi setuptools3
9SRC_URI[sha256sum] = "25b5d0b42fd000320bd7830b349e3b696435f3b329810427a6bcce6a5492cc5c"
10
11# http://errors.yoctoproject.org/Errors/Details/184715/
12# Can't find required file: ../src/google/protobuf/descriptor.proto
13CLEANBROKEN = "1"
14
15UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
16
17DEPENDS += "protobuf"
18
19RDEPENDS:${PN} += " \
20    python3-datetime \
21    python3-json \
22    python3-logging \
23    python3-netclient \
24    python3-numbers \
25    python3-pkgutil \
26    python3-six \
27    python3-unittest \
28"
29
30# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
31BBCLASSEXTEND = "native nativesdk"
32
33DISTUTILS_BUILD_ARGS += "--cpp_implementation"
34DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
35
36do_compile:prepend:class-native () {
37    export KOKORO_BUILD_NUMBER="1"
38}
39