1SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
6SRC_URI[sha256sum] = "3527b7af26106cbc65a040bcc84839a3566ec1b051bb0bfe953631e704b0ff7d"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "prompt_toolkit"
11
12RDEPENDS:${PN} += " \
13    ${PYTHON_PN}-core \
14    ${PYTHON_PN}-six \
15    ${PYTHON_PN}-terminal \
16    ${PYTHON_PN}-threading \
17    ${PYTHON_PN}-wcwidth \
18    ${PYTHON_PN}-datetime \
19    ${PYTHON_PN}-shell \
20    ${PYTHON_PN}-image \
21    ${PYTHON_PN}-asyncio \
22    ${PYTHON_PN}-xml \
23"
24
25BBCLASSEXTEND = "native nativesdk"
26