1SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
6SRC_URI[sha256sum] = "3527b7af26106cbc65a040bcc84839a3566ec1b051bb0bfe953631e704b0ff7d"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "prompt_toolkit"
11
12RDEPENDS:${PN} += " \
13    python3-core \
14    python3-six \
15    python3-terminal \
16    python3-threading \
17    python3-wcwidth \
18    python3-datetime \
19    python3-shell \
20    python3-image \
21    python3-asyncio \
22    python3-xml \
23"
24
25BBCLASSEXTEND = "native nativesdk"
26