1SUMMARY  = "Control process attributes through prctl"
2DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
3process' behaviour. Usage of the function is fairly messy though, due to \
4limitations in C and linux. This module provides a nice non-messy python(ic) \
5interface."
6SECTION = "devel/python"
7LICENSE = "GPL-3.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1475481f9ec754d758859bd2c75f6f6f"
9
10S = "${WORKDIR}/git"
11B = "${S}"
12
13SRCREV = "5e12e398eb5c4e30d7b29b02458c76d2cc780700"
14SRC_URI = "git://github.com/seveas/python-prctl;protocol=https;branch=main \
15           file://0001-support-cross-complication.patch \
16"
17inherit setuptools3 python3native
18PIP_INSTALL_PACKAGE = "python_prctl"
19
20DEPENDS += "libcap"
21
22